基于Swoole开发PHP扩展

来自PHP百科全书
跳转至: 导航搜索

Swoole-1.9.8 增加了一个 PHP_API.hpp 模块,对 ZendAPI 进行了封装,可以大大简化 PHP 扩展的开发。 Swoole 的 C++ 模块只能用 C++ 语言开发,不支持 C 语言。

准备工作

  • 目前只支持 PHP7 ,另外必须安装了 1.9.7 或更高版本的 Swoole 扩展
  • 需要一份 Swoole 的源码

编写代码

编译扩展

运行程序